Create a DWG export settings with default values.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static ExportDWGSettings Create( Document document, string name, DWGExportOptions options ) |
Visual Basic |
---|
Public Shared Function Create ( _ document As Document, _ name As String, _ options As DWGExportOptions _ ) As ExportDWGSettings |
Visual C++ |
---|
public: static ExportDWGSettings^ Create( Document^ document, String^ name, DWGExportOptions^ options ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
Document where created settings is saved.
- name
- Type: System..::..String
The name specified to this settings.
- options
- Type: Autodesk.Revit.DB..::..DWGExportOptions
Initialize settings by using values in DWGExportOptions.
Return Value
The new DWG export settings instance.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | ExistOrEmpty |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |