Gets the default element type id with the given DefaultElementType id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2015
Syntax
Return Value
The element type id.
Examples
CopyC#
private bool IsWallUsingDefaultType(Document document, Wall wall)
{
ElementId defaultElementTypeId = document.GetDefaultElementTypeId(ElementTypeGroup.WallType);
return (wall.WallType.Id == defaultElementTypeId);
}
CopyVB.NET
Private Function IsWallUsingDefaultType(document As Document, wall As Wall) As Boolean
Dim defaultElementTypeId As ElementId = document.GetDefaultElementTypeId(ElementTypeGroup.WallType)
Return (wall.WallType.Id = defaultElementTypeId)
End Function
Exceptions
See Also