Creates a new project document with no template file specified.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public Document NewProjectDocument( UnitSystem unitSystem ) |
Visual Basic |
---|
Public Function NewProjectDocument ( _ unitSystem As UnitSystem _ ) As Document |
Visual C++ |
---|
public: Document^ NewProjectDocument( UnitSystem unitSystem ) |
Parameters
- unitSystem
- Type: Autodesk.Revit.DB..::..UnitSystem
The unit system used for the new document.
Return Value
The newly created document.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |