Gets the Element referenced by a unique id string.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public Element GetElement( string uniqueId ) |
Visual Basic |
---|
Public Function GetElement ( _ uniqueId As String _ ) As Element |
Visual C++ |
---|
public: Element^ GetElement( String^ uniqueId ) |
Parameters
- uniqueId
- Type: System..::..String
The element unique id, whose referenced Element will be retrieved from the model.- UniqueId
Return Value
The element referenced by the input argument.
Remarks
nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if the input id string doesn't reference to a valid Element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |