Sets the LinePattern associated to this element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public void SetLinePattern( LinePattern newLinePattern ) |
Visual Basic |
---|
Public Sub SetLinePattern ( _ newLinePattern As LinePattern _ ) |
Visual C++ |
---|
public: void SetLinePattern( LinePattern^ newLinePattern ) |
Parameters
- newLinePattern
- Type: Autodesk.Revit.DB..::..LinePattern
The new LinePattern object.
Remarks
The data stored inside the input LinePattern will be copied into this element.
The input LinePattern itself will not be associated with the element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The Line Pattern is not valid. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |