Creates a non-vertically compound structure comprised of parallel layers.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static CompoundStructure CreateSimpleCompoundStructure( IList<CompoundStructureLayer> layers ) |
Visual Basic |
---|
Public Shared Function CreateSimpleCompoundStructure ( _ layers As IList(Of CompoundStructureLayer) _ ) As CompoundStructure |
Visual C++ |
---|
public: static CompoundStructure^ CreateSimpleCompoundStructure( IList<CompoundStructureLayer^>^ layers ) |
Parameters
- layers
- Type: System.Collections.Generic..::..IList<(Of <(<'CompoundStructureLayer>)>)>
An array which describes the parallel layers of this compound structure.
Return Value
A newly created compound structure.
Remarks
All layers are in the core, i.e. there are no shell layers created.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | One or more layers is not valid. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |