Activates the symbol to ensure that its geometry is accessible.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void Activate() |
Visual Basic |
---|
Public Sub Activate |
Visual C++ |
---|
public: void Activate() |
Remarks
Symbols that are not used in the document may be deactivated to conserve memory and regeneration time.
When the symbol is inactive, its geometry is empty and should not be accessed.
In order to access geometry of a symbol that is not active in the document, first check its IsActive
property. Note that until the document is regenerated, the newly activated symbol's geometry
will still be empty.