Adds a subfolder to the folder path with the given name.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public void AddSubFolder( string folderName ) |
Visual Basic |
---|
Public Sub AddSubFolder ( _ folderName As String _ ) |
Visual C++ |
---|
public: void AddSubFolder( String^ folderName ) |
Parameters
- folderName
- Type: System..::..String
The name of the folder.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The folderName is not a valid folder name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path) should not exceeds 259. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |