Return a transform representing the relative position of any
individual bar in the set.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public Transform GetBarPositionTransform( int barPositionIndex ) |
Visual Basic |
---|
Public Function GetBarPositionTransform ( _ barPositionIndex As Integer _ ) As Transform |
Visual C++ |
---|
public: Transform^ GetBarPositionTransform( int barPositionIndex ) |
Parameters
- barPositionIndex
- Type: System..::..Int32
An index between 0 and (NumberOfBarPositions-1).
Return Value
The position of a bar in the set relative to the first position.
Remarks
The transform is a translation along the distribution path.
It can be applied to the results of GetCenterlineCurves() to
produce any bar in the rebar set. For barPositionIndex=0,
the identity transform is always returned.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RebarShapeDrivenAccessor doesn't contain a valid rebar reference. |