Sets a new parameter value of this subelement given a parameter id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public void SetParameterValue( ElementId parameterId, ParameterValue pValue ) |
Visual Basic |
---|
Public Sub SetParameterValue ( _ parameterId As ElementId, _ pValue As ParameterValue _ ) |
Visual C++ |
---|
public: void SetParameterValue( ElementId^ parameterId, ParameterValue^ pValue ) |
Parameters
- parameterId
- Type: Autodesk.Revit.DB..::..ElementId
Parameter id.
- pValue
- Type: Autodesk.Revit.DB..::..ParameterValue
New value for the parameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | parameterId does not identify a valid parameter of this subelement. -or- The parameter parameterId is not modifiable for this subelement. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |