Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static FailureDefinitionId RoomsInSameRegion { get; } |
Visual Basic |
---|
Public Shared ReadOnly Property RoomsInSameRegion As FailureDefinitionId Get |
Visual C++ |
---|
public: static property FailureDefinitionId^ RoomsInSameRegion { FailureDefinitionId^ get (); } |