Sets the entire text with the given text in a plain text form.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public void SetPlainText( string plainText ) |
Visual Basic |
---|
Public Sub SetPlainText ( _ plainText As String _ ) |
Visual C++ |
---|
public: void SetPlainText( String^ plainText ) |
Parameters
- plainText
- Type: System..::..String
The given text in a plain text form.
Remarks
Any individual formatting present before will be lost after applying this function
and the text will have uniform formatting.
If the text does not end with a carriage return character ('\r') one will be added.
An empty string is allowed.
The given text should have no more than 30,000 characters, not counting a terminating carriage return character ('\r').
Newline characters ('\n') are not allowed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | plainText (excluding a carriage return character ('\r') at the end) has more than 30,000 characters. -or- plainText contains invalid characters such as a newline character. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |