The product of the specified number and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public static UV operator *(
	UV left,
	double value
)
Visual Basic
Public Shared Operator * ( _
	left As UV, _
	value As Double _
) As UV
Visual C++
public:
static UV^ operator *(
	UV^ left, 
	double value
)

Parameters

left
Type: Autodesk.Revit.DB..::..UV
The vector to multiply with the value.
value
Type: System..::..Double
The value to multiply with the specified vector.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException Thrown when the specified value is an infinite number.
Autodesk.Revit.Exceptions..::..ArgumentNullException Thrown when left is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also