For Conceptual Mass and Curtain Panel families,
indicate whether the specified dimension-driving
parameter is locked.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool IsParameterLocked( FamilyParameter familyParameter ) |
Visual Basic |
---|
Public Function IsParameterLocked ( _ familyParameter As FamilyParameter _ ) As Boolean |
Visual C++ |
---|
public: bool IsParameterLocked( FamilyParameter^ familyParameter ) |
Parameters
- familyParameter
- Type: Autodesk.Revit.DB..::..FamilyParameter
Return Value
True if the parameter is lockable and is locked; false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this family is not a Conceptual Mass or Curtain Panel family. |