Sets the Analytical Projection to the supplied Analytical Projection Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2011

Syntax

C#
public void SetAnalyticalProjectionType(
	AnalyticalProjectionType projectionType
)
Visual Basic
Public Sub SetAnalyticalProjectionType ( _
	projectionType As AnalyticalProjectionType _
)
Visual C++
public:
void SetAnalyticalProjectionType(
	AnalyticalProjectionType projectionType
)

Parameters

projectionType
Type: Autodesk.Revit.DB.Structure..::..AnalyticalProjectionType
Analytical Projection Type to which the Analytical Model should project.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException projectionType is not valid for this Sketch component.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also