Identifies if the input layer can be designated as a variable thickness layer.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public bool CanLayerBeVariable( int variableLayerIndex ) |
Visual Basic |
---|
Public Function CanLayerBeVariable ( _ variableLayerIndex As Integer _ ) As Boolean |
Visual C++ |
---|
public: bool CanLayerBeVariable( int variableLayerIndex ) |
Parameters
- variableLayerIndex
- Type: System..::..Int32
Index of a layer in the CompoundStructure.
Return Value
True if the input layer may be a variable thickness layer and false otherwise.
Remarks
A layer whose layer function is StructuralDeck may not be designated as a variable layer.