The gbXML opening type attribute.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public gbXMLOpeningType Type { get; } |
Visual Basic |
---|
Public ReadOnly Property Type As gbXMLOpeningType Get |
Visual C++ |
---|
public: property gbXMLOpeningType Type { gbXMLOpeningType get (); } |
Remarks
The type of the opening is based on the family category for
the opening and in what element it is contained in:
- If it is a Window it will have a type of OperableWindow.
- If it is a Door it will have a type of NonSlidingDoor.
- If the opening is contained in a Roof it will have a type of FixedSkylight.
- If it is a Curtain Wall Panel, the opening will default to a type of FixedWindow. If the material specified for the family, and the material transparency is less than 3%, the opening will be ignored as a solid panel.