Gets fabrication ancillaries of the specified type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2017 Subscription Update
Syntax
Visual Basic |
---|
Public Function GetAncillaries ( _
type As FabricationAncillaryType, _
includeKits As Boolean, _
filterKits As Boolean _
) As IList(Of Integer) |
Parameters
- type
- Type: Autodesk.Revit.DB.Fabrication..::..FabricationAncillaryType
The type of ancillaries to get.
- includeKits
- Type: System..::..Boolean
Whether or not to include ancillary kits as well.
- filterKits
- Type: System..::..Boolean
Whether kits should be filtered to only those that contain the specified ancillary type.
Return Value
An array of ancillary identifiers.
Exceptions
See Also