The force vector applied to the point load, oriented according to OrientTo setting.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2016

Syntax

C#
public XYZ ForceVector { get; set; }
Visual Basic
Public Property ForceVector As XYZ
	Get
	Set
Visual C++
public:
property XYZ^ ForceVector {
	XYZ^ get ();
	void set (XYZ^ value);
}

Remarks

The default force unit is kN for metric, and kip for imperial. Use UnitUtils class methods to convert value from or to internal units.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException When setting this property: A non-optional argument was NULL

See Also