Distance to the next fabric wire item
Can be 0 to be used with offset along wire.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public double Distance { get; set; } |
Visual Basic |
---|
Public Property Distance As Double Get Set |
Visual C++ |
---|
public: property double Distance { double get (); void set (double value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for distance is not a number |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for distance must be between 0 and 30000 feet. |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |