Apply the local print settings to global for all documents.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void Apply() |
Visual Basic |
---|
Public Sub Apply |
Visual C++ |
---|
public: void Apply() |
Remarks
This method will change the settings for the current printer to match what is set in the
Print Manager. When the user attempts to print with this printer in the future, the changes
made by the API session will be visible.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others. |