Removes all sweeps or reveals from the compound structure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void ClearWallSweeps( WallSweepType wallSweepType ) |
Visual Basic |
---|
Public Sub ClearWallSweeps ( _ wallSweepType As WallSweepType _ ) |
Visual C++ |
---|
public: void ClearWallSweeps( WallSweepType wallSweepType ) |
Parameters
- wallSweepType
- Type: Autodesk.Revit.DB..::..WallSweepType
The type of a wall sweep.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures. |