The document's state of modifiability.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool IsModifiable { get; } |
Visual Basic |
---|
Public ReadOnly Property IsModifiable As Boolean Get |
Visual C++ |
---|
public: property bool IsModifiable { bool get (); } |
Remarks
This is not a permanent state such as, for example IsReadOnlyFile.
Value of this property changes dynamically multiple times within the life-time of an open document.
Regardless of the mode a document is opened with, the model can only be modified inside an open transaction.
Furthermore, even with a transaction open, the model is not always modifiable.
Though this is rather a rare situation, it can happen, most likely during model regeneration, failure processing, or some events.
An attempt to modify a non-modifiable document will result in throwing a ModificationOutsideTransactionException.
See also IsReadOnly