Adds a new MEPSize to the segment.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void AddSize( MEPSize size ) |
Visual Basic |
---|
Public Sub AddSize ( _ size As MEPSize _ ) |
Visual C++ |
---|
public: void AddSize( MEPSize^ size ) |
Parameters
- size
- Type: Autodesk.Revit.DB..::..MEPSize
The new MEPSize to be added.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | There is already a same size in the settings. -or- The size already exists in the segment. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |