Returns a global parameter, if any, currently associated with this parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016 Subscription Update
Syntax
C# |
---|
public ElementId GetAssociatedGlobalParameter() |
Visual Basic |
---|
Public Function GetAssociatedGlobalParameter As ElementId |
Visual C++ |
---|
public: ElementId^ GetAssociatedGlobalParameter() |
Return Value
Id of a global parameter or InvalidElemetnId.
Remarks
InvalidElementId is returned in case this parameter is not associated with any global parameter.
InvalidElementId is also returned if called for a parameter that cannot even be associated
with a global parameters (i.e. a non-parametrizable parameter or parameter with a formula).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | This parameter does not exist in the document anymore. |