The gas viscosity of the asset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public double GasViscosity { get; set; } |
Visual Basic |
---|
Public Property GasViscosity As Double Get Set |
Visual C++ |
---|
public: property double GasViscosity { double get (); void set (double value); } |
Remarks
Values are in kilograms per feet-second (kg/(ft · s)) and must be non-negative.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for gasViscosity must be non-negative. |
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the asset must be gas to set this property. |