Gets graphic overrides for an element in the view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public OverrideGraphicSettings GetElementOverrides( ElementId elementId ) |
Visual Basic |
---|
Public Function GetElementOverrides ( _ elementId As ElementId _ ) As OverrideGraphicSettings |
Visual C++ |
---|
public: OverrideGraphicSettings^ GetElementOverrides( ElementId^ elementId ) |
Parameters
- elementId
- Type: Autodesk.Revit.DB..::..ElementId
The element.
Return Value
An object representing all graphic overrides of the element elementId in view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | elementId is not a valid Element identifier. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | View does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes. |