Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public bool IsPhaseCreatedValid( ElementId createdPhaseId ) |
Visual Basic |
---|
Public Function IsPhaseCreatedValid ( _ createdPhaseId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool IsPhaseCreatedValid( ElementId^ createdPhaseId ) |
Parameters
- createdPhaseId
- Type: Autodesk.Revit.DB..::..ElementId
The id of a Phase.
Return Value
True if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element, false otherwise.
Remarks
Acts as a validator for setting the property CreatedPhaseId.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |