Sets member element ids for the assembly instance. All existing members are cleared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public void SetMemberIds(
	ICollection<ElementId> memberIds
)
Visual Basic
Public Sub SetMemberIds ( _
	memberIds As ICollection(Of ElementId) _
)
Visual C++
public:
void SetMemberIds(
	ICollection<ElementId^>^ memberIds
)

Parameters

memberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to set for the assembly instance.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException This method may not be called during dynamic update.

See Also