Gets the associated family parameter of an element parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public FamilyParameter GetAssociatedFamilyParameter( Parameter elementParameter ) |
Visual Basic |
---|
Public Function GetAssociatedFamilyParameter ( _ elementParameter As Parameter _ ) As FamilyParameter |
Visual C++ |
---|
public: FamilyParameter^ GetAssociatedFamilyParameter( Parameter^ elementParameter ) |
Parameters
- elementParameter
- Type: Autodesk.Revit.DB..::..Parameter
The parameter of an element in family.
Return Value
The associated family parameter if there is an association between them, returns nullNothingnullptra null reference (Nothing in Visual Basic) if not.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"elementParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic). |