Remove the fixed direction from a segment.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetSegmentVariableDirection( int iSegment ) |
Visual Basic |
---|
Public Sub SetSegmentVariableDirection ( _ iSegment As Integer _ ) |
Visual C++ |
---|
public: void SetSegmentVariableDirection( int iSegment ) |
Parameters
- iSegment
- Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).
Remarks
The segment's angle will be allowed to vary, with a range of 90 degrees. The segment must have at least two constraints.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | iSegment is not between 0 and NumberOfSegments. |