Returns whether the curve loop is open or closed, as determined by an internal flag.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public bool IsOpen() |
Visual Basic |
---|
Public Function IsOpen As Boolean |
Visual C++ |
---|
public: bool IsOpen() |
Return Value
True if the CurveLoop is marked open, false if marked closed.
Remarks
Some routines in Revit may set the CurveLoop to be marked "open" or "closed" in spite of the actual geometry of the curves.
In these special cases, the CurveLoop class does not require that the CurveLoop is correctly marked.