Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static IFCGeometryInfo CreateFaceGeometryInfo( ExporterIFC ExporterIFC, Plane Plane, XYZ ProjDir, double epsilon, bool createRepresentations ) |
Visual Basic |
---|
Public Shared Function CreateFaceGeometryInfo ( _ ExporterIFC As ExporterIFC, _ Plane As Plane, _ ProjDir As XYZ, _ epsilon As Double, _ createRepresentations As Boolean _ ) As IFCGeometryInfo |
Visual C++ |
---|
public: static IFCGeometryInfo^ CreateFaceGeometryInfo( ExporterIFC^ ExporterIFC, Plane^ Plane, XYZ^ ProjDir, double epsilon, bool createRepresentations ) |
Parameters
- ExporterIFC
- Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
- Plane
- Type: Autodesk.Revit.DB..::..Plane
The plane in which the face handles must lie.
- ProjDir
- Type: Autodesk.Revit.DB..::..XYZ
The normal vector to the input plane.
- epsilon
- Type: System..::..Double
The epsilon value used to process surfaces.
- createRepresentations
- Type: System..::..Boolean
Indicates if this should also create geometry representation handles.
Return Value
The new geometry info container.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |