Adds an intersection element to the divided surface.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public void AddIntersectionElement( ElementId newIntersectionElemId ) |
Visual Basic |
---|
Public Sub AddIntersectionElement ( _ newIntersectionElemId As ElementId _ ) |
Visual C++ |
---|
public: void AddIntersectionElement( ElementId^ newIntersectionElemId ) |
Parameters
- newIntersectionElemId
- Type: Autodesk.Revit.DB..::..ElementId
The intersection element to be added.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The element newIntersectionElemId is not a level, grid, reference plane, or a curve element whose category is lines and reference lines. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |