Get a reference to a line segment connecting two adjacent grid nodes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public Reference GetGridSegmentReference(
	GridNode gridNode,
	GridSegmentDirection gridSegmentDirection
)
Visual Basic
Public Function GetGridSegmentReference ( _
	gridNode As GridNode, _
	gridSegmentDirection As GridSegmentDirection _
) As Reference
Visual C++
public:
Reference^ GetGridSegmentReference(
	GridNode gridNode, 
	GridSegmentDirection gridSegmentDirection
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode
gridSegmentDirection
Type: Autodesk.Revit.DB..::..GridSegmentDirection

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeExceptionThrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ], or when the adjacent grid node specified by gridSegmentDirection is out of range.

See Also