Wire length for this wire item
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public double WireLength { get; set; } |
Visual Basic |
---|
Public Property WireLength As Double Get Set |
Visual C++ |
---|
public: property double WireLength { double get (); void set (double value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for length is not a number |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for length must be greater than 0 and no more than 30000 feet. |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |