Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
Visual Basic |
---|
Public Sub New ( _
category As BuiltInCategory, _
inverted As Boolean _
) |
Visual C++ |
---|
public:
ElementCategoryFilter(
BuiltInCategory category,
bool inverted
) |
Parameters
- category
- Type: Autodesk.Revit.DB..::..BuiltInCategory
The category to match.
- inverted
- Type: System..::..Boolean
True if the filter should match all elements which are not of the given category.
See Also