Identifies the hook length for a hook type
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public double GetHookLength( ElementId hookId ) |
Visual Basic |
---|
Public Function GetHookLength ( _ hookId As ElementId _ ) As Double |
Visual C++ |
---|
public: double GetHookLength( ElementId^ hookId ) |
Parameters
- hookId
- Type: Autodesk.Revit.DB..::..ElementId
id of the hook type
Return Value
The hook length for a hook type
Remarks
If the AutoCalcHookLengths property is turned off, the default hook length will be returned
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | the rebar hook type id hookId is not valid |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |