Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public FamilyInstanceCreationData NewFamilyInstanceCreationData( Curve curve, FamilySymbol symbol, Level level, StructuralType structuralType ) |
Visual Basic |
---|
Public Function NewFamilyInstanceCreationData ( _ curve As Curve, _ symbol As FamilySymbol, _ level As Level, _ structuralType As StructuralType _ ) As FamilyInstanceCreationData |
Visual C++ |
---|
public: FamilyInstanceCreationData^ NewFamilyInstanceCreationData( Curve^ curve, FamilySymbol^ symbol, Level^ level, StructuralType structuralType ) |
Parameters
- curve
- Type: Autodesk.Revit.DB..::..Curve
The curve where the instance is based.
- symbol
- Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
- level
- Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
- structuralType
- Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.