The calculated and settable thermal properties of the RoofType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public ThermalProperties ThermalProperties { get; }
Visual Basic
Public ReadOnly Property ThermalProperties As ThermalProperties
	Get
Visual C++
public:
property ThermalProperties^ ThermalProperties {
	ThermalProperties^ get ();
}

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the roof has no thermal properties. Curtain roofs do not store thermal properties.

See Also