Gets the name of the reference plane in the family corresponding to the given family instance reference.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public string GetReferenceName( Reference reference ) |
Visual Basic |
---|
Public Function GetReferenceName ( _ reference As Reference _ ) As String |
Visual C++ |
---|
public: String^ GetReferenceName( Reference^ reference ) |
Parameters
- reference
- Type: Autodesk.Revit.DB..::..Reference
The family instance reference.
Return Value
Returns the name of the reference plane in the family corresponding to the given family instance reference. If the reference doesn't correspond to a named reference plane, returns an empty string.
Remarks
If the given family reference corresponds to a named reference plane in the instance's family, the name of that reference plane will be returned.
Otherwise, an empty string will be returned.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |