Returns the profile with generated fillets that defines the shape of the Fabric Sheet bending.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public CurveLoop GetBendProfileWithFillets() |
Visual Basic |
---|
Public Function GetBendProfileWithFillets As CurveLoop |
Visual C++ |
---|
public: CurveLoop^ GetBendProfileWithFillets() |
Return Value
The bend profile with generated fillets that defines the shape of the fabric sheet bending for bent fabric sheet, for flat fabric sheet nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.
Remarks
Returned curve loop is created automatically as a result of adding fillets to bend profile.
The returned profile defines the center-curve of a wire.
Note that bent Fabric Sheets can have planar geometry, but flat Fabric Sheets are always planar.