If this value is greater than 0.0, in the MassEnergyAnalytical model a building "core" geometry
will be created for each solid geometry of the mass instance.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public double MassZoneCoreOffset { get; set; } |
Visual Basic |
---|
Public Property MassZoneCoreOffset As Double Get Set |
Visual C++ |
---|
public: property double MassZoneCoreOffset { double get (); void set (double value); } |
Remarks
The resulting "core" geometry created inside the mass instance solid geometry
is offset inwards at each level intersecting the mass instance solid geometry by the value
of the offset. This "core" geometry is automatically cut from its parent mass instance geometry
in the MassEnergyAnalyticalModel.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The massZoneCoreOffset is less than zero. |