Converts a pair of cloud project and model GUIDs to a valid cloud path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2021

Syntax

C#
public static ModelPath ConvertCloudGUIDsToCloudPath(
	string region,
	Guid projectId,
	Guid modelId
)
Visual Basic
Public Shared Function ConvertCloudGUIDsToCloudPath ( _
	region As String, _
	projectId As Guid, _
	modelId As Guid _
) As ModelPath
Visual C++
public:
static ModelPath^ ConvertCloudGUIDsToCloudPath(
	String^ region, 
	Guid projectId, 
	Guid modelId
)

Parameters

region
Type: System..::..String
The region of the BIM 360 account and project which contains this model. Please see the reference values, like CloudRegionUS and CloudRegionEMEA, and the new regions from release note.
projectId
Type: System..::..Guid
The GUID of the cloud project which contains the model.
modelId
Type: System..::..Guid
The GUID of the Revit cloud model.

Return Value

The cloud model path.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..CentralModelException The cloud model is missing.
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException The central server could not be reached.
Autodesk.Revit.Exceptions..::..RevitServerUnauthenticatedUserException You must sign in to Autodesk 360 in order to complete action.
Autodesk.Revit.Exceptions..::..RevitServerUnauthorizedException You are unauthorized to access this resource.

See Also