Renames the workset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015 Subscription Update
Syntax
C# |
---|
public static void RenameWorkset( Document aDoc, WorksetId worksetId, string name ) |
Visual Basic |
---|
Public Shared Sub RenameWorkset ( _ aDoc As Document, _ worksetId As WorksetId, _ name As String _ ) |
Visual C++ |
---|
public: static void RenameWorkset( Document^ aDoc, WorksetId^ worksetId, String^ name ) |
Parameters
- aDoc
- Type: Autodesk.Revit.DB..::..Document
The document in which the workset is accessed.
- worksetId
- Type: Autodesk.Revit.DB..::..WorksetId
The workset Id.
- name
- Type: System..::..String
The workset name.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | aDoc is not a workshared document. -or- name is an empty string or contains only whitespace. -or- name cannot include prohibited characters. -or- The given workset name is already in use. -or- There is no workset in the document with this id. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction. |