The Poisson ratio of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public XYZ PoissonRatio { get; set; }
Visual Basic
Public Property PoissonRatio As XYZ
	Get
	Set
Visual C++
public:
property XYZ^ PoissonRatio {
	XYZ^ get ();
	void set (XYZ^ value);
}

Remarks

This property cannot be used to set the Poisson ratio for wood-based and isotropic materials. For such assets, use setPoissonRatio instead.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InapplicableDataException When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.

See Also