The grade of wood used in a wood-based asset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public string WoodGrade { get; set; } |
Visual Basic |
---|
Public Property WoodGrade As String Get Set |
Visual C++ |
---|
public: property String^ WoodGrade { String^ get (); void set (String^ value); } |
Remarks
Applies to wood-based structural assets.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be wood to set this property. |