Creates a new FreeFormElement from a copy of the input geometry.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static FreeFormElement Create( Document document, Solid geometry ) |
Visual Basic |
---|
Public Shared Function Create ( _ document As Document, _ geometry As Solid _ ) As FreeFormElement |
Visual C++ |
---|
public: static FreeFormElement^ Create( Document^ document, Solid^ geometry ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document in which the element is to be created.
- geometry
- Type: Autodesk.Revit.DB..::..Solid
The input geometry.
Return Value
returns a new FreeFormElement
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a family document, nor a document editing an in-place family. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction. |