Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public IList<Reference> GetReferences( FamilyInstanceReferenceType referenceType ) |
Visual Basic |
---|
Public Function GetReferences ( _ referenceType As FamilyInstanceReferenceType _ ) As IList(Of Reference) |
Visual C++ |
---|
public: IList<Reference^>^ GetReferences( FamilyInstanceReferenceType referenceType ) |
Parameters
- referenceType
- Type: Autodesk.Revit.DB..::..FamilyInstanceReferenceType
The family reference type.
Return Value
Returns all the family instance references corresponding to reference planes and reference lines of the given reference type.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |