Get Id of the Workset which owns the element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public WorksetId GetWorksetId( ElementId id ) |
Visual Basic |
---|
Public Function GetWorksetId ( _ id As ElementId _ ) As WorksetId |
Visual C++ |
---|
public: WorksetId^ GetWorksetId( ElementId^ id ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..ElementId
Id of the element.
Return Value
Id of the Workset which owns the element.
Remarks
Each element belongs to one and only one workset.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |